Comparing builds

Builds dnsvizor@2022-02-20 13:22:07Z on freebsd-12 and dnsvizor@2024-03-02 20:43:08Z on freebsd-12

Compare in reverse direction

Opam packages removed

arp.3.0.0
asn1-combinators.0.2.6
base.v0.14.3
bheap.2.0.0
bigarray-compat.1.1.0
conf-gmp.4
conf-gmp-powm-sec.3
conf-m4.1
cstruct.6.0.1
cstruct-lwt.6.0.1
cstruct-sexp.6.0.1
dns.6.1.4
duration.0.2.0
eqaf.0.8
ethernet.3.0.0
gmap.0.3.0
gmp-freestanding.6.2.1
happy-eyeballs.0.1.3
hex.1.4.0
ipaddr-sexp.5.2.0
lru.0.3.0
lwt-dllist.1.0.1
macaddr-cstruct.5.2.0
macaddr-sexp.5.2.0
menhir.20220210
menhirLib.20220210
menhirSdk.20220210
metrics.0.4.0
mirage-block.3.0.0
mirage-channel.4.0.1
mirage-clock.4.0.0
mirage-clock-freestanding.4.0.0
mirage-console.5.1.0
mirage-device.2.0.0
mirage-flow.3.0.0
mirage-fs.4.0.0
mirage-kv.4.0.0
mirage-logs.1.2.0
mirage-net.4.0.0
mirage-profile.0.9.1
mirage-random.3.0.0
mirage-time.3.0.0
mmap.1.1.0
mtime.1.4.0
num.1.4
ocaml-compiler-libs.v0.12.4
ocaml-freestanding.0.6.6
ocamlgraph.2.0.0
parse-argv.0.2.0
parsexp.v0.14.2
ppx_cstruct.6.0.1
ppx_derivers.1.2.1
ppx_sexp_conv.v0.14.3
ppxlib.0.24.0
psq.0.2.0
ptime.1.0.0
randomconv.0.1.3
seq.base
sexplib.v0.14.0
sexplib0.v0.14.0
solo5-bindings-hvt.0.6.9
stdlib-shims.0.3.0
zarith.1.12
zarith-freestanding.1.12

New opam packages installed

angstrom.0.16.0
bigstringaf.0.9.1
conf-which.1
emile.1.1
mirage-unikernel-dnsvizor-hvt.0.0.2
ocaml-solo5.0.8.3
ocaml-syntax-shims.1.0.0
opam-monorepo.0.4.0
pecu.0.6
solo5.0.7.5
stringext.1.6.0
uri.4.4.0
uutf.1.0.3

Opam packages with version changes

base64.3.5.0->3.5.1
cmdliner.1.0.4->1.2.0
conf-pkg-config.2->3
cppo.1.6.8->1.6.9
csexp.1.5.1->1.5.2
dune.3.0.2->3.14.0
dune-configurator.3.0.2->3.14.0
functoria.3.1.1->4.4.2
functoria-runtime.3.0.3->4.4.2
ipaddr.5.2.0->5.5.0
lwt.5.5.0->5.7.0
macaddr.5.2.0->5.5.0
mirage.3.10.8->4.4.2
mirage-runtime.3.10.8->4.4.2
ocaml.4.13.1->4.14.1
ocaml-base-compiler.4.13.1->4.14.1
ocaml-src.4.13.1->4.14.1
ocamlbuild.0.14.1->0.14.3
ocamlfind.1.9.3->1.9.6
topkg.1.0.5->1.0.7

Duniverse parsing error

not a single root package found in opam switch export

Opam packages with changes in their opam file

ocaml-options-vanilla.1 (and additional changes)


New environment variables added

OPAMROOT /tmp
ORB_DATA 2

Environment variables changed

PKG_CONFIG_PATH /tmp/myswitch/build/_opam/lib/pkgconfig->/tmp/myswitch/lib/pkgconfig
PREFIX /tmp/myswitch/build/_opam->/tmp/myswitch
SWITCH_PATH /tmp/myswitch/build->myswitch

System packages removed

readline 8.1.1

System packages changed

bash 5.1.16->5.2.26_1
builder 0.3.0-5-g087108a->0.3.2.15.gbb3a686
ca_root_nss 3.75->3.93_2
curl 7.81.0->8.6.0
expat 2.4.4->2.6.0
git 2.35.1->2.44.0
gmake 4.3_2->4.3_3
gmp 6.2.1->6.3.0
orb a16d89b->0.0.2.15.g5a9081c
pkg 1.17.5_1->1.20.9_1
pkgconf 1.8.0,1->2.0.3_2,1