Comparing builds

Builds builder@2023-11-20 12:38:33Z on ubuntu-18.04 and builder@2023-02-22 21:25:49Z on ubuntu-18.04

Compare in reverse direction

New opam packages installed

base.v0.15.1
conf-pkg-config.2
cstruct-sexp.6.1.1
ipaddr-sexp.5.3.1
num.1.4
ocaml-compiler-libs.v0.12.4
parsexp.v0.15.0
ppx_cstruct.6.1.1
ppx_derivers.1.2.1
ppx_sexp_conv.v0.15.1
ppxlib.0.29.1
sexplib.v0.15.1
stdlib-shims.0.3.0

Opam packages with version changes

bigstringaf.0.9.1->0.9.0
cmdliner.1.2.0->1.1.1
csexp.1.5.2->1.5.1
cstruct.6.2.0->6.1.1
dns.7.0.3->7.0.0
dns-client.7.0.3->7.0.0
dns-client-lwt.7.0.3->7.0.0
dune.3.11.1->3.7.0
dune-configurator.3.11.1->3.7.0
h2.0.11.0->0.9.0
happy-eyeballs.0.6.0->0.5.0
happy-eyeballs-lwt.0.6.0->0.5.0
hpack.0.11.0->0.9.0
http-lwt-client.0.2.5->0.2.2
ipaddr.5.5.0->5.3.1
lwt.5.7.0->5.6.1
macaddr.5.5.0->5.3.1
metrics.0.4.1->0.4.0
mirage-crypto.0.11.2->0.11.0
mirage-crypto-ec.0.11.2->0.11.0
mirage-crypto-pk.0.11.2->0.11.0
mirage-crypto-rng.0.11.2->0.11.0
mirage-crypto-rng-lwt.0.11.2->0.11.0
ocaml.5.1.0->5.0.0
ocaml-base-compiler.5.1.0->5.0.0
ocamlfind.1.9.6->1.9.5
sexplib0.v0.16.0->v0.15.1
tls.0.17.1->0.16.0
tls-lwt.0.17.1->0.16.0
x509.0.16.5->0.16.4
zarith.1.13->1.12

Opam packages with changes in their opam file

ocamlbuild.0.14.2 (and additional changes)


ocaml-options-vanilla.1 (and additional changes)


New system packages added

pkg-config 0.29.1-0ubuntu2

System packages changed

binutils 2.30-21ubuntu1~18.04.9->2.30-21ubuntu1~18.04.8
binutils-common 2.30-21ubuntu1~18.04.9->2.30-21ubuntu1~18.04.8
binutils-x86-64-linux-gnu 2.30-21ubuntu1~18.04.9->2.30-21ubuntu1~18.04.8
ca-certificates 20230311ubuntu0.18.04.1->20211016ubuntu0.18.04.1
git 1:2.17.1-1ubuntu0.18->1:2.17.1-1ubuntu0.16
git-man 1:2.17.1-1ubuntu0.18->1:2.17.1-1ubuntu0.16
libbinutils 2.30-21ubuntu1~18.04.9->2.30-21ubuntu1~18.04.8
libcurl3-gnutls 7.58.0-2ubuntu3.24->7.58.0-2ubuntu3.22
libgssapi-krb5-2 1.16-2ubuntu0.4->1.16-2ubuntu0.3
libk5crypto3 1.16-2ubuntu0.4->1.16-2ubuntu0.3
libkrb5-3 1.16-2ubuntu0.4->1.16-2ubuntu0.3
libkrb5support0 1.16-2ubuntu0.4->1.16-2ubuntu0.3
libperl5.26 5.26.1-6ubuntu0.7->5.26.1-6ubuntu0.6
libssl1.1 1.1.1-1ubuntu2.1~18.04.23->1.1.1-1ubuntu2.1~18.04.21
libxml2 2.9.4+dfsg1-6.1ubuntu1.9->2.9.4+dfsg1-6.1ubuntu1.8
linux-libc-dev 4.15.0-213.224->4.15.0-204.215
openssl 1.1.1-1ubuntu2.1~18.04.23->1.1.1-1ubuntu2.1~18.04.21
orb 0.0.2-15-g5a9081c->0.0.2-10-g7a43a0a
perl 5.26.1-6ubuntu0.7->5.26.1-6ubuntu0.6
perl-base 5.26.1-6ubuntu0.7->5.26.1-6ubuntu0.6
perl-modules-5.26 5.26.1-6ubuntu0.7->5.26.1-6ubuntu0.6