Comparing builds

Builds builder@2024-04-15 12:08:51Z on debian-11 and builder@2022-09-10 13:36:24Z on debian-11

Compare in reverse direction

Opam packages removed

dns-client-lwt.7.0.99~dev
mirage-crypto-rng-lwt.0.11.3
tls-lwt.0.17.4

New opam packages installed

arp.3.0.0
base.v0.15.0
ca-certs-nss.3.80
conf-pkg-config.2
cstruct-lwt.6.1.1
cstruct-sexp.6.1.1
ethernet.3.0.0
ipaddr-sexp.5.3.1
lwt-dllist.1.0.1
macaddr-cstruct.5.3.1
mirage-clock.4.2.0
mirage-flow.3.0.0
mirage-kv.5.0.0
mirage-net.4.0.0
mirage-no-solo5.1
mirage-no-xen.1
mirage-profile.0.9.1
mirage-random.3.0.0
mirage-time.3.0.0
num.1.4
ocaml-compiler-libs.v0.12.4
parsexp.v0.15.0
ppx_cstruct.6.1.1
ppx_derivers.1.2.1
ppx_sexp_conv.v0.15.1
ppxlib.0.27.0
sexplib.v0.15.1
stdlib-shims.0.3.0
tcpip.7.1.2
tls-mirage.0.15.3

Opam packages with version changes

angstrom.0.16.0->0.15.0
base64.3.5.1->3.5.0
bigstringaf.0.9.1->0.9.0
builder.0.3.99~dev->0.3.2~dev
cmdliner.1.2.0->1.1.1
csexp.1.5.2->1.5.1
cstruct.6.2.0->6.1.1
dns.7.0.99~dev->6.3.0
dns-client.7.0.99~dev->6.3.0
dune.3.15.0->3.4.1
dune-configurator.3.15.0->3.4.1
duration.0.2.1->0.2.0
faraday.0.8.2->0.8.1
faraday-lwt.0.8.2->0.8.1
faraday-lwt-unix.0.8.2->0.8.1
h2.0.11.0->0.9.0
happy-eyeballs.0.6.0->0.3.0
happy-eyeballs-lwt.0.6.0->0.3.0
hpack.0.11.0->0.9.0
http-lwt-client.0.2.6->0.0.7
ipaddr.5.5.0->5.3.1
lru.0.3.1->0.3.0
lwt.5.7.0->5.6.1
macaddr.5.5.0->5.3.1
metrics.0.4.1->0.4.0
mirage-crypto.0.11.3->0.10.6
mirage-crypto-ec.0.11.3->0.10.6
mirage-crypto-pk.0.11.3->0.10.6
mirage-crypto-rng.0.11.3->0.10.6
mtime.2.0.0->1.4.0
ocaml.4.14.2->4.14.0
ocaml-base-compiler.4.14.2->4.14.0
ocamlbuild.0.14.3->0.14.1
ocamlfind.1.9.6->1.9.5
psq.0.2.1->0.2.0
ptime.1.1.0->1.0.0
sexplib0.v0.16.0->v0.15.1
tls.0.17.4->0.15.3
topkg.1.0.7->1.0.5
x509.0.16.5->0.16.0
zarith.1.13->1.12

Opam packages with changes in their opam file

ocaml-options-vanilla.1 (and additional changes)


New environment variables added

PKG_CONFIG_PATH /tmp/myswitch/lib/pkgconfig

New system packages added

libglib2.0-0 2.66.8-1
libglib2.0-data 2.66.8-1
pkg-config 0.29.2-1
shared-mime-info 2.0-1
xdg-user-dirs 0.17-2

System packages changed

adduser 3.118+deb11u1->3.118
base-files 11.1+deb11u9->11.1+deb11u1
bash 5.1-2+deb11u1->5.1-2+b3
bsdextrautils 2.36.1-8+deb11u2->2.36.1-8+deb11u1
bsdutils 1:2.36.1-8+deb11u1->1:2.36.1-8
builder 0.3.2-15-gbb3a686->0.3.1
debian-archive-keyring 2021.1.1+deb11u1->2021.1.1
dpkg 1.20.13->1.20.9
dpkg-dev 1.20.13->1.20.12
file 1:5.39-3+deb11u1->1:5.39-3
git 1:2.30.2-1+deb11u2->1:2.30.2-1
git-man 1:2.30.2-1+deb11u2->1:2.30.2-1
gpgv 2.2.27-2+deb11u2->2.2.27-2
grep 3.6-1+deb11u1->3.6-1
gzip 1.10-4+deb11u1->1.10-4
libblkid1 2.36.1-8+deb11u1->2.36.1-8
libc-bin 2.31-13+deb11u8->2.31-13+deb11u2
libc-dev-bin 2.31-13+deb11u8->2.31-13+deb11u4
libc6 2.31-13+deb11u8->2.31-13+deb11u4
libc6-dev 2.31-13+deb11u8->2.31-13+deb11u4
libcurl3-gnutls 7.74.0-1.3+deb11u11->7.74.0-1.3+deb11u3
libdpkg-perl 1.20.13->1.20.12
libexpat1 2.2.10-2+deb11u5->2.2.10-2+deb11u3
libgnutls30 3.7.1-5+deb11u4->3.7.1-5
libgssapi-krb5-2 1.18.3-6+deb11u4->1.18.3-6+deb11u1
libk5crypto3 1.18.3-6+deb11u4->1.18.3-6+deb11u1
libkrb5-3 1.18.3-6+deb11u4->1.18.3-6+deb11u1
libkrb5support0 1.18.3-6+deb11u4->1.18.3-6+deb11u1
liblzma5 5.2.5-2.1~deb11u1->5.2.5-2
libmagic-mgc 1:5.39-3+deb11u1->1:5.39-3
libmagic1 1:5.39-3+deb11u1->1:5.39-3
libmount1 2.36.1-8+deb11u1->2.36.1-8
libnghttp2-14 1.43.0-1+deb11u1->1.43.0-1
libpcre2-8-0 10.36-2+deb11u1->10.36-2
libperl5.32 5.32.1-4+deb11u3->5.32.1-4+deb11u2
libseccomp2 2.5.1-1+deb11u1->2.5.1-1
libsmartcols1 2.36.1-8+deb11u1->2.36.1-8
libssl1.1 1.1.1w-0+deb11u1->1.1.1k-1+deb11u1
libsystemd0 247.3-7+deb11u4->247.3-6
libtasn1-6 4.16.0-2+deb11u1->4.16.0-2
libtinfo6 6.2+20201114-2+deb11u2->6.2+20201114-2
libudev1 247.3-7+deb11u4->247.3-6
libuuid1 2.36.1-8+deb11u1->2.36.1-8
libxml2 2.9.10+dfsg-6.7+deb11u4->2.9.10+dfsg-6.7+deb11u2
linux-libc-dev 5.10.209-2->5.10.140-1
mount 2.36.1-8+deb11u1->2.36.1-8
ncurses-base 6.2+20201114-2+deb11u2->6.2+20201114-2
ncurses-bin 6.2+20201114-2+deb11u2->6.2+20201114-2
openssl 1.1.1w-0+deb11u1->1.1.1n-0+deb11u3
orb 0.0.2-18-g232dbb8->0.0.2-4-ged60f97
perl 5.32.1-4+deb11u3->5.32.1-4+deb11u2
perl-base 5.32.1-4+deb11u3->5.32.1-4+deb11u2
perl-modules-5.32 5.32.1-4+deb11u3->5.32.1-4+deb11u2
sysvinit-utils 2.96-7+deb11u1->2.96-7
tar 1.34+dfsg-1+deb11u1->1.34+dfsg-1
tzdata 2024a-0+deb11u1->2021a-1+deb11u1
util-linux 2.36.1-8+deb11u1->2.36.1-8
zlib1g 1:1.2.11.dfsg-2+deb11u2->1:1.2.11.dfsg-2