Job traceroute

README

Skip to builds

traceroute

This is a MirageOS unikernel which conducts a traceroute to the given host. Read the blog post.

Installation from source

To install this unikernel from source, you need to have opam (>= 2.1.0) and ocaml (>= 4.08.0) installed. Also, mirage is required (>= 4.0.0). Please follow the installation instructions.

The following steps will clone this git repository and compile the unikernel:

$ git clone https://github.com/roburio/traceroute.git
$ mirage configure -t <your-favourite-target>
$ make depend
$ mirage build

Installing as binary

Reproducible binaries are available at https://builds.robur.coop/job/traceroute/

Questions?

Please open an issue if you have questions, feature requests, or comments.

Builds

Back to readme

Including failed builds here.